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A Introduction

The TextManager is a program providing support when working with multilingual 
texts. The TextManager is a database with integral editor, but does not have any 
automatic translation function.
Translation programs which support the Windows standard can be used in 
conjunction with the TextManager without problem.

The TextManager:

• facilitates reliable and convenient working for translators and users. 
• offers effective protection of resources from third party access through an 

integrated encryption function.
• contains filter functions which simplify finding and editing entries in large files.
• supports the entry of multi-line texts.
• can be adapted individually in its presentation.
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1 Typographical Conventions

The following typographical conventions are used in the TextManager User 
Manual to highlight text elements:

Dialog box title Dialogfeld Options

Dialog box components (e.g. 
dialog field sections)

Dialogfeldbereich Construction

File names user.rsx, *.rsc

References to other chapters Refer also to Chapter Options
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A User interface

Elements of the TextManager user interface

db_cpl_msg

The TextManager user interface contains various higher level sections. Subjects 
in this chapter:

• Menu

• Working section

• Context menu
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1 Menu

You have access to most of the TextManager commands via the menus. 
Subjects in this chapter:

• Pull-down menu, File

Here you will find commands that you need for dealing with files and for the data 
interchange.

• Pull-down menu, Edit

Here you will find commands for editing keys and data records. Some of these 
commands can also be found in the Context menu of the display section. 

• Pull-down menu, Help

Here you have access to the integrated help system and will find information 
about the program release.
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1.1 Pull-down menu, File

menu_file

File > New
Creates a new, blank RSX file.

File > Open
Opens an existing RSX file.

File > Save
Saves the current file.

File > Save as
Saves the current file under a new name.

File > Import
Imports data records from another RSX file or an RSC file.

File > Export
Exports data records to a new or existing RSC file.

File > Options
Offers setting possibilities for importing data records and for protecting files.
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1.2 Pull-down menu, Edit

menu_edit

Edit > Generate key
Generates a new data record with a key and blank data fields.

Edit > Remove key
Deletes the marked data record from the file.

Edit > Key copy
Copies the marked key to the clipboard.

Edit > Copy
Copies the marked data record to the clipboard.

Edit > Insert
Inserts the content of the clipboard into the marked line.
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1.3 Pull-down menu, Help

menu_help

Help > Content
Displays the TextManager help.

Help > Info
Displays TextManager program information.
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2 Working section

The working section of the TextManager contains various sections Subjects in 
this chapter:

• Data filter

Data records can be filtered by various methods.

• Data section

Lists the data records sorted according to keys.

• Text editor

Displays the text of the selected data record in the active language for editing.

• Status line

Shows information about the data records.
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2.1 Data filter

Finding data records is simplified with the filter function. In particular in files with 
a large number of data records the data filter is very helpful. You can combine 
the various filters to restrict the data display.

db_filter_line

Input field
Defines the term to be filtered.

Filter
Activates the data filter. 
If no additional switch is pressed, the data records are  displayed in which the 
stated string occurs in a data field.

Key
Activates the filter function for the data key.
In combination with the pressed filter the data records are displayed in which the 
stated string is contained in the key.

Old
Activates the filter function for data records marked as outdated.
In combination with the pressed filter the data records are displayed which are 
labeled as Outdated and in which the stated string is contained in the data field.

Compare whole text
Selects the filter function for the complete text.
In combination with the pressed filter only data records are displayed when the 
complete content of a data field matches the stated string.
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2.2 Data section

In the data section the data records of the opened file are displayed. The data 
section contains one column for the key and a column for each of the various 
languages.

db_data

You can set the translation language by clicking the column heading. 
Furthermore, you adapt the width and the position of the columns as required.

If you press the right mouse key in the data section, you can edit existing data 
records and generate a new key.

Adjusting the translation language:

• Click the desired column heading to set it as the current translation language. 
Now you can change the texts in this language in the Text editor.

Changing the column width:

• Move the mouse over the right edge of the column heading until the mouse 
pointer changes to a double arrow.

• Press the left mouse key and with the left mouse key still pressed pull the 
column to the required width.

• You can set the optimum column width by double clicking on the right edge of 
the required column. 

Moving a column:

• Click a column heading with the left mouse key.
• With the left mouse key still pressed drag the language to the required 

position.

Note: The arrangement and the width of the columns are permanently saved. 
The translation language is reset to "German" during each program start.

Editing the data records:

• Click a data row with the right mouse key.
• Choose the required editing option in the Context menu.
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2.3 Text editor

The text editor displays the text of the marked data record in the current 
language. Text modifications are only possible here.

Multi-line text in the text editor

db_text_editor

Modifying the texts in data fields:

• Choose a language by clicking a language in the data section. The active 
language is displayed to the left of the input field.

• Mark the data record containing the text to be changed.
• Change the text in the entry field.
• Click the Accept button to accept the text changes in the data record.

Note: You can produce multi-line texts by clicking the data record with the right 
mouse key and selecting the Multi-line option in the context menu.
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2.4 Status line

Information on the number of data records is displayed in the status line. Here 
you can see the number of filtered data records and the number of all data 
records. 
Example: 4/11 (4 data records filtered/11 data records total).
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3 Context menu

Depending from which location you call the context menu, it s displayed in 
various forms. Subjects in this chapter:

• Reduced context menu

• Expanded context menu
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3.1 Reduced context menu

context_menu_reduced

The reduced context menu is displayed when you click outside a line with the 
right mouse key.

Generate key
Generates a new data record with a key and blank data fields.
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3.2 Expanded context menu

context_menu_enlarged

The expanded context menu is displayed when you click in a marked line with 
the right mouse key.

Generate key
Generates a new data record with a key and blank data fields.

Remove key
Deletes the marked data record from the file.

Key copy
Copies the marked key to the clipboard.

Copy
Copies the marked data record to the clipboard.

Insert
Inserts the content of the clipboard into the marked line.

Keyword
Marks the marked line as keyword.

Multi-line
Activates multi-line data fields for the marked line.

Outdated
Identifies the marked line as Outdated.
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B Command Reference

The command reference contains a list of all commands with description. 
Subjects in this chapter:

• Processing files

• Editing keys

• Filtering data
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1 Processing files

In this section you will find instructions and information on processing files. 
Furthermore, the methods of data interchange using the import and export 
function are described. Subjects in this chapter:

• New

• Open

• Save

• Save as

• Import

• Export

• Options
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1.1 New

Creates a new, blank RSX file.

If you have processed an RSX file, you are first requested to save the changes. 
The new RSX file is still unnamed and contains neither data nor a key.
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1.2 Open

Opens an existing RSX file.

If you have processed an RSX file, you are first requested to save the changes. 
In the Open dialog box find the file which you would like to open, then double-
click it to open it.

If you open a protected RSX file, you are requested to enter a password.

Dialog box Entering the password

db_password

Enter the password and click OK to open the protected RSX file.
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1.3 Save

Saves the current RSX file. 

If the file is still unnamed, the dialog box Save as is opened where you have to 
define a storage location and the file name.
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1.4 Save as

Saves the current RSX file under a new name.

To do this, the dialog box Save as is opened where you have to define a storage 
location and the file name.
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1.5 Import

Imports data records from another RSX file or an RSC file.

In the Open dialog box find the file, the data records of which you would like to 
import and then double-click it to import the data records it contains.

As standard, all data records of the selected file are imported, whereby existing 
texts are not replaced. 
Select File>Options, if you would like to modify the standard import options.
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1.6 Export

Exports data records to an RSC file. 

In the Export dialog box you can set which data records are to be exported.

Dialog box Export

db_export

Current selection
Exports the data records displayed by the current Filter. This switch cannot be 
used when the Filter is switched off.

Only errors
Exports only the data records which contain errors.
Note: A data record is erroneous when it contains three question marks (???) or 
when an entry is missing completely.

Language list
Only exports the marked languages.
Mark the languages which you want to export with the mouse. A multiple choice 
is possible.
Note: The language selection works in combination with the Only errors and 
Current selection switches. Thus a data record is not exported if it contains 
errors in an unmarked language.

Select all
Marks all languages in the list.

Click OK to execute the export. In the following dialog box you define the storage 
location and the file name in the RSC file.
Click Cancel to terminate the data export.
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1.7 Options

Influences settings for Import and file protection.

Dialog box Options

The Options dialog box contains the tabs Import and File protection.

Tab Import

db_optionen_import

Languages pick list
Determines the language to be imported.

Do not generate a new key
Causes no new key to be generated on data import.

Do not replace existing text
Stops existing text from being overwritten on data import.

Tab File protection

db_optionen_dateischutz

Password
Protects the file from unauthorized access. This password is requested on 
opening the file.

Master password
Protects certain options from unauthorized access. The master password is only 
required at the time of changing the password. Other application possibilities are 
in development.
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2 Editing keys

Keys are unambiguous relationships, the terms of which are assigned in various 
languages. Keys can consist of many lines and may be identified in various 
ways. In this section you will find important information about handling keys. 
Subjects in this chapter:

• Generate key

• Remove key

• Key copy

• Copy

• Insert

• Keyword

• Multi-line

• Outdated
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2.1 Generate key

Generates a new data record with a key and blank data fields.
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2.2 Remove key

Deletes the marked data record from the file.

A confirmation query occurs before the marked data record is deleted. Note: 
Deletion cannot be undone.
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2.3 Key copy

Copies the marked key to the clipboard.

Note: This command only copies the key text into the clipboard. It can for 
example be inserted into the filter field in another RSX file and used for filtering.



Command reference Editing keys
Copy

TextManager  35

2.4 Copy

Copies the marked data record to the clipboard.

The texts of all data fields of the marked data record are copied to the clipboard 
and can be inserted into the data fields of another data record with Insert. Note: 
Existing texts are overwritten without warning.
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2.5 Insert

Inserts the content of the clipboard into the marked line.

Texts which were previously copied into the clipboard with Copy are inserted into 
the data fields of the marked line. Note: Existing texts are overwritten without 
warning.
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2.6 Keyword

Marks the marked line as keyword.

The marking is displayed as a green K symbol in the key column. Keywords are 
normally used for calling program functions (for example, ALT+F to activate the 
Menu>File) and should be identified for better differentiation.

Note: Texts in multi-line data fields cannot be used as keywords.
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2.7 Multi-line

Activates multi-line data fields for the marked line.

The marking is displayed as a green M symbol in the key column. Multi-line texts 
can be written in all data fields of the line marked in this way. In the text editor 
press the Enter key to produce a line break.

Note: Since data fields only permit a single-line representation, line breaks are 
shown with a break symbol.
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2.8 Outdated

Identifies the marked line as Outdated.

The marking is displayed as a red symbol in the key column. 
Texts which are not to be used in future, but are to be retained for information, 
should be identified as outdated.
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3 Filtering data

You can speed up searching for texts using various filter functions. Furthermore, 
the filter function can be used to check for text matches. In this section you will 
find information on filtering data records. Subjects in this chapter:

• Filter

• Key

• Old

• Compare whole text
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3.1 Filter

Filters data records according to strings and parts of strings.

To use the data filter you have to write the string to be found in the input field. 
The data fields of all languages are compared with the entered string. If you 
switch on the Filter button, the data records are filtered.

Filter switched on

db_filter_on

With the Filter button pressed, only the data records are displayed in which the 
entered string is present in one of the data fields. Text matches are shown in red.

Filter switched off

db_filter_off

The data filter also works when the Filter button is not pressed. In this case the 
matching texts are shown in red and all data records are displayed.

Notes

You can apply the filter also to keys, to data records marked with the identifier 
Old and complete text matches. The various filter methods can also be 
combined.
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3.2 Key

Filters keys according to entered strings.

If you want to apply the Key filter, you have to write the string to be found in the 
input field. In order that the filter compares the entered string with the keys, the 
Key button must be switched on.

Filter and Key switched on

db_filter_key_on

With the Filter and Key buttons pressed, only the data records are displayed in 
which the entered string is present in the key fields. Text matches are shown in 
red.

Filter off and Key switched on

db_filter_key_off

The Key filter also works when only the Key button is pressed. In this case the 
matching texts are shown in red and all data records are displayed.

Notes

You can also use the Key filter in conjunction with the Old filter. Here is an 
example:

db_filter_key_old_on
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3.3 Old

Filters data records which have been labeled as Outdated.

If you want to use the Old filter, you have to switch on the buttons Filter and Old. 
Optionally, you can write a string into the entry field to compare the old data 
records with it.

Old filter without string in the entry field

db_filter_old1_on

With the Filter and Old buttons pressed all data records are shown which are 
labeled as old.

Old filter with string in the entry field

db_filter_old2_on

With the Filter and Old buttons pressed all the data records are shown which are 
labeled as old and in which the entered string is present in one of the data fields. 
Text matches are shown in red.

Notes

You can apply the Old filter in conjunction with the Key filter and the Compare 
whole text filter.
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3.4 Compare whole text

Filters data records according to entered strings; the whole text is compared.

To use the data filter you have to write the string to be found in the input field. All 
data fields of all languages are compared with the entered string. If you switch on 
the Filter button and the Compare whole text, the data records are filtered.

Filter and Compare whole text switched on

db_filter_complete_text1_on

With the Filter and Compare whole text buttons pressed only those data records 
are displayed in which the complete entered string is present in the data fields. 
Text matches are shown in red.

Filter and Compare whole text switched off

db_filter_complete_text2_on

The filter also works when only the Compare whole text button is pressed. In this 
case the matching texts are shown in red and all data records are displayed.

Notes

You can apply the Compare whole text filter also to data records which are 
marked with the Old identifier.
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C Definition of terms

RSC file

Uncompiled resource file. These files contain the source text of the translations 
in text format (separated by tab stop). RSC files should not be published, 
because they are not protected. Generally, RSC files are only used for data 
interchange. For example when texts are sent to a translator.

RSX file

Compiled resource file. These files contain the compiled text of the translations. 
They are needed to guarantee the multilingual features. RSX files can only be 
opened and edited with the TextManager.

Key

A key is a unique attribute. Multilingual texts are organized with the aid of keys 
and can be assigned to objects. The content of each key must be unique and 
should have an incremental number, or better still a prefix and an incremental 
number. Example: LABEL_0001.
The term key is often used in conjunction with data records, because each data 
record must have a unique attribute.

Data record

A data record is a closed entity within a database.
In the TextManager data records are shown in tabular form, so a line within the 
text manager corresponds to a data record. 
A data record always consists of a key and the data fields containing the texts for 
various languages.

Data field

A data field is a constituent part of a data record. In contrast to the key, the 
content of the data field does not need to be unique.
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